Awarie i problemy na forum

Tu będą umieszczane ważne informacje związane z funkcjonowaniem forum oraz rozwiązania ewentualnych problemów technicznych.

Awarie i problemy na forum

Postprzez Łukasz. » 7 lis 2009, o 22:03

Jest temat , w którym piszemy co byśmy zmienili.Niestety, czasem na forum coś się dzieje, a to jakiś dział nie otwiera się, a to szukajka się popsuła... I każdy wali zazwyczaj osobny temat, których robi się całe multum. Proponuję, by nie pisać oddzielnych tematów, jak zauważycie coś niepokojącego, tylko napisać to w tym temacie, po prostu, żeby było lepiej :wink:

Więc ja zacznę, Niedawno zauważyłem małe błędy w tytułach tematów:
[img][570:471]http://img405.imageshack.us/img405/2962/temat.png[/img]
Nie jest to uciążliwe, ale jednak zmienia się prawidłowy tytuł pewnego tematu na stronie głównej
Obrazek

"...gdy ktoś, kto mi jest światełkiem, gaśnie nagle w biały dzień..."
Avatar użytkownika
Łukasz.
@admin
@admin
 
Posty: 4771
Dołączył(a): 7 mar 2008, o 20:20
Lokalizacja: WLKP -> PWL
Pochwały: 13
Pojazdy: Renault megane phI classic '97, MZ etz 150 '87

Awarie i problemy na forum

Postprzez Pani Kontekstowa » 7 lis 2009, o 22:03

Pani Kontekstowa
 

Postprzez Piotrek » 9 lis 2009, o 16:41

Wszystko to wynika ze specyfikacji jezyka html a konkretniej to tego jak niektóre znaki zapisuje się w kodzie strony. Otóż znak < nie zapisuje się jako < tylko w formie "zakodowanej" jako ciąg 4 innych znaków a mianowicie: &lt;

Skrypt na stronie głównej ma za zadanie podawanie pierwszych 10 znaków tematu. W kodowej wersji temat: Rakieta<ping> jest tak zapisany: Rakieta&lt;ping ponga&gt; a więc pierwsze 10 znaków to: Rakieta&lt, tak też właśnie wyświetla skrypt na stronie głównej.

Tak, więc jak widać awaria to, to nie jest żadna :-) tylko jak pisałem, taka jest specyfikacja języka html.

Aby to nie występowało trzeba byłoby zrobić aby skrypt ignorował te znaki. Tylko czy to ma sens?
Avatar użytkownika
Piotrek
@admin
@admin
 
Posty: 3656
Dołączył(a): 19 mar 2007, o 19:13
Pochwały: 10
Pojazdy: Opel Vectra B, 2000 Edition

Postprzez Łukasz. » 9 lis 2009, o 20:30

Piotrek napisał(a):Wszystko to wynika ze specyfikacji jezyka html a konkretniej to tego jak niektóre znaki zapisuje się w kodzie strony. Otóż znak < nie zapisuje się jako < tylko w formie "zakodowanej" jako ciąg 4 innych znaków a mianowicie: &lt;

A, nie bo myślałem, że to coś sknocone jest :wink:
Tylko czy to ma sens?

Wychodzi na to, iż nie :yes:
Obrazek

"...gdy ktoś, kto mi jest światełkiem, gaśnie nagle w biały dzień..."
Avatar użytkownika
Łukasz.
@admin
@admin
 
Posty: 4771
Dołączył(a): 7 mar 2008, o 20:20
Lokalizacja: WLKP -> PWL
Pochwały: 13
Pojazdy: Renault megane phI classic '97, MZ etz 150 '87


Powrót do Sprawy dotyczące forum

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 4 gości